Saltar al contenido principal
Procore

¿Cómo afecta el requerimiento de Transport Layer Security v1.2 a los usuarios?

Respuesta

Para la mayoría de los usuarios de Procore, el requisito de Transport Layer Security (TLS) v1.2 no tendrá ningún impacto adverso en el desempeño, la estabilidad o la seguridad. Sin embargo, puede haber algunos aspectos de TLS v1.2 que ciertos usuarios deben conocer. Estas consideraciones se tratan en las siguientes secciones.

Contexto

La arquitectura de seguridad de red de Procore se basa en el protocolo Transport Layer Security (TLS) para garantizar que la interacción del usuario con Procore a través de Internet se produzca de forma segura sin que las transmisiones sean vulnerables a entidades externas. TLS cifra un canal entre dos puntos finales (por ejemplo, entre un navegador web y un servidor web) para asegurar la privacidad y la confiabilidad de los datos transmitidos a través del canal de comunicaciones. El beneficio principal de TLS es la protección de los datos de la aplicación web contra la divulgación y modificación no autorizadas cuando se transmite entre clientes (navegadores web) y el servidor de aplicaciones web, y entre el servidor de aplicaciones web y el back-end u otros componentes empresariales no basados en navegador.

Debido a la preocupación por proteger sus datos y cumplir con los estándares de la industria, a partir de mediados del segundo trimestre de 2019, Procore solo admitirá conexiones de red TLS v1.2. Los usuarios deberán conectarse a Procore utilizando el protocolo TLS v1.2 para evitar cualquier interrupción en el servicio.

Fechas e hitos importantes

Estas son algunas fechas e hitos importantes relacionados con la actualización de TLS v1.2:

  • Febrero de 2019 - anuncio inicial del requisito de TLS v1.2, soporte para TLS v1.0/1.1 obsoleto.
  • 1 de mayo de 2019: Finalización del soporte para TLS v1.0/1.1. Solo se admitirán conexiones TLS v1.2 después de esta fecha.

Versiones del navegador compatibles con TLS v1.2

Para garantizar un servicio ininterrumpido, los usuarios de Procore deben adoptar una de las siguientes versiones de navegador que admita TLS v1.2.

  • Google Chrome: v30 o posterior
  • Mozilla Firefox - v27 o posterior
  • Microsoft Internet Explorer - v11 o versión posterior
  • Safari para Mac OS X - v7 o versión posterior
  • Edge para Windows 10

Soporte para dispositivos móviles

Dispositivos Apple iOS
  • Todos los dispositivos Apple que ejecutan iOS v9.0.0 y versiones posteriores son compatibles con TLS v1.2.
    • Todos los dispositivos iOS que no sean el iPhone original (2007), iPhone 3G, iPhone 3GS, iPhone 4 y iPad original (2010) se pueden actualizar al menos a iOS 9.
    • Las versiones actuales de Procore para iOS requieren iOS 11 o versión posterior.
Dispositivos Android
  • Los dispositivos Android que ejecutan v4.4 y posteriores del sistema operativo Android son compatibles con TLS v1.2.
  • Los dispositivos Android que ejecutan v4.1 a v4.3 del sistema operativo Android pueden admitir TLS v1.2 según la configuración del sistema, pero están deshabilitados para la compatibilidad con TLS v1.2 de forma predeterminada.
  • Los dispositivos Android que ejecutan v4.0 y versiones anteriores del sistema operativo Android no son compatibles con TLS v1.2.

Ver también